Fehler bei der Umstellung auf die Amazon API v5

  • Hallo,


    Bei der Umstellung auf die Amazon API v5, mache ich wohl etwas falsch. ||


    Ich erhalte ich in den Listen, beim Produktimport, folgende Meldung:

    Nachricht: Request Exception: [400] Client error: `POST https://webservices.amazon.de/paapi5/searchitems` resulted in a `400 Bad Request` response:
    {"__type":"com.amazon.paapi5#ValidationException","Errors":[{"Code":"InvalidParameterValue","Message":"The value All (truncated...)

    - Wenn ich eine Abteilung angebe, verabschiedet sich die Seite komplett. Also Wordpress Fehlerbehebung: Kritischer Fehler auf der Seite.

    In den Listen dann folgende Meldung:


    Nachricht: Request Exception: [400] Client error: `POST https://webservices.amazon.de/paapi5/searchitems` resulted in a `400 Bad Request` response:
    {"__type":"com.amazon.paapi5#ValidationException","Errors":[{"Code":"InvalidParameterValue","Message":"The value Sportin (truncated...)

    - Es werden keine Produkte importiert!

  • Hallo,


    Kannst du mal 1-2 Beispiele posten was du da genau importierst?


    lg Christof

  • Also z-B. E-Lastenfahrrad ... Aber das Produkt ist meistens egal, glaube ich.

    Ich gehe auf "Listen" - erstelle eine für Amazon Import und Suche dann das jew. Produkt.

    Ich habe jetzt nochmal versch. Versuche in den Shopeinstellungen gemacht. Wenn die API-Version auf Auto steht, geht es ... manchmal. Auf v4 geht es so gut wie immer, auf v5, so gut wie nie...

  • Also z-B. E-Lastenfahrrad ... Aber das Produkt ist meistens egal, glaube ich.

    Ich gehe auf "Listen" - erstelle eine für Amazon Import und Suche dann das jew. Produkt.

    Ich habe jetzt nochmal versch. Versuche in den Shopeinstellungen gemacht. Wenn die API-Version auf Auto steht, geht es ... manchmal. Auf v4 geht es so gut wie immer, auf v5, so gut wie nie...

    Okay, habe die Ursache gefunden. Liegt an einem Encoding-Problem.


    Ist mit dem nächsten Update korrigiert.


    lg Christof

  • Ich hänge mich jetzt mal rein: Ist es denn bekannt, wann Amazon die alte Api4 abschaltet? Wenn ja: wann?

  • Amazon hat erneut die Abschaltung der API 4.0 verschoben. Jetzt ist es der 09. März 2020. :)


    Orignalmeldung ins deutsche übersetzt:


    #################################

    Guten Tag, Partner(in),


    Wir möchten Sie darüber informieren, dass alle Ihre Anwendungen, die Aufrufe an Amazon's Produktwerbe-API Version 4.0 (PA API 4.0) tätigen, bis zum 9. März 2020 auf Amazon's Produktwerbe-API Version 5.0 (PA API 5.0) aktualisiert werden müssen.


    Die PA API 5.0 ist eine einfachere, granulare und konsistente API, die es Ihnen ermöglicht, Ihre Inhalte schnell und einfach mit Amazon zu verknüpfen.


    Wichtige Funktionen und Änderungen

    • Zugang zu Informationen über die neuesten Angebote und Produkte in der gesamten Amazon-Produktdatenbank / dem Amazon-Katalog, wie z.B. Preisnachlässe, Multiwährungsformate und Versandberechtigung
    • Neuere, verbesserte Wege, um die relevantesten und aktuellsten Produktinformationen zu erhalten
    • Schnelle Integration und einfachere Entwicklung mit geringeren Engineering-Kosten durch Verwendung gängiger Werkzeuge und Sprachen

    Sie können sowohl PA API 4.0 als auch PA API 5.0 bis zum 9. März 2020 ohne Unterbrechung weiter verwenden. Nach diesem Datum werden wir die PA API 4.0 abschalten, und jede Anwendung, die sie aufruft, wird nicht mehr in der Lage sein, Amazon-Produktinformationen abzurufen.


    #################################

  • Hi,

    ich benutzte die ganze Zeit für mein Amazon-Affiliate das affiliate-toolkit Standard.

    Mit diesen PA API 4.0 als auch PA API 5.0 habe ich keine Ahnung und ich denke auch nie darüber etwas gemacht? Mit dem Plugin?


    Muss ich da auch etwas umstellen oder beachten oder gilt das PA API nur für spezielle Programmierer?


    Grüße

    Claudi:)

  • Hallo Claudi,


    Mit diesen PA API 4.0 als auch PA API 5.0 habe ich keine Ahnung und ich denke auch nie darüber etwas gemacht? Mit dem Plugin?


    Muss ich da auch etwas umstellen oder beachten oder gilt das PA API nur für spezielle Programmierer?


    wenn du die aktuelle Version vom Plugin hast, sollte v5 automatisch aktiv sein.


    Und ja,das betrifft auch dich.


    lg Chirstof

  • Wie mit meiner Mail von eben mitgeteilt (ticket) geht bei mir kein Update! Auch mir vorigem Deinstallieren nicht, kommt ständig Fehlermeldung.

    Das ist jetzt aber sehr schlecht!! :(


    Was wäre den die aktuellste Version? Wenn ich reinschaue steht:


    Affiliate Toolkit 2.4.3

  • Bei zwei meiner Projekte läuft es unter der Api 5 (alles wird brav aktualisiert). Bei zwei weiteren geht es nicht (Aktualisierung bricht offenbar ab, auch die Produkte des anderen Shops [Ebay] werden dann nicht mehr mit einer Aktualisierung versorgt). Komisch. Ich stelle mal wieder auf Api 5 um und schaue mir dann einmal das Error Log unter Debug an.

  • Hallo,

    Ticket schau ich gleich mal...

    Was wäre den die aktuellste Version? Wenn ich reinschaue steht:

    2.6.2 ist die aktuelle version: News & Plugin Updates




    Komisch. Ich stelle mal wieder auf Api 5 um und schaue mir dann einmal das Error Log unter Debug an.

    Eventuell dort ein Konflikt mit anderen Plugins. Hier kannst du mal testweise auf v4 zurückstellen. Mit ASA gibts hier z.b. ein Problem und es funktioniert gar nicht mehr.


    lg Christof

  • Habe nun immer noch keine wirkliche Hilfe bekommen auf meine Fragen und Problem. Da ich auch über das Ticket keine Nachricht bekomme, probiere ich es hier noch einmal:


    Also ich habe wohl noch die Alte Version drauf: 2.4.3. und brauche dringend die aktuelle.

    Nach der Lizenzverlängerung kann ich trotzdem kein Update machen. Egal ob ich es vorher deinstalliere oder einfach ein Update drüber mache kommt folgende Fehlermeldung :

    Der Link, dem du gefolgt bist, ist abgelaufen.

    Bitte versuche es nochmal.


    In meinem Kundenkonto sehe ich nur das und habe auch beides ausprobiert:

    Name herunterladen Dateien
    Affiliate-Toolkit Standard Affiliate-Toolkit
    Affiliate-Toolkit Standard Affiliate-Toolkit

    Der Download ohne Versionsnummer am Ende ist immer die aktuellste Version.

  • Hallo

    Da ich auch über das Ticket keine Nachricht bekomme, probiere ich es hier noch einmal:

    Ich habe dir auf das Ticket eigentlich bereits geantwortet.


    Also ich habe wohl noch die Alte Version drauf: 2.4.3. und brauche dringend die aktuelle.

    Deine Lizenz ist noch bis nächstes Jahr gültig. Wenn du also das aktuelle Paket von der Webseite herunterlädst und danach deine Lizenz eingibst, solltest du das aktuelle Paket haben. Ich sehe auch das du bereits deine Webseite aktiviert hattest.


    Und bitte zukünftig einen eigenen Thread aufmachen und nicht einfach unter ein anderes Thema posten...


    lg Christof

  • Okay, habe die Ursache gefunden. Liegt an einem Encoding-Problem.


    Ist mit dem nächsten Update korrigiert.


    lg Christof

    Hi Christoph,


    leider besteht mein ursprüngliches Problem in diesem Thread, auch nach dem Update noch genauso wie vorher. Ich nutze die Version Version 2.6.2

    Also z-B. E-Lastenfahrrad ... Aber das Produkt ist meistens egal, glaube ich.

    Ich gehe auf "Listen" - erstelle eine für Amazon Import und Suche dann das jew. Produkt.

    Ich habe jetzt nochmal versch. Versuche in den Shopeinstellungen gemacht. Wenn die API-Version auf Auto steht, geht es ... manchmal. Auf v4 geht es so gut wie immer, auf v5, so gut wie nie...

    LG:rolleyes:

  • Lieber Christof, wie bereits schon mehrmals geschrieben - funktioniert es nach dem herunterladen NICHT. Ich habe beim Ticket direkt auf die Mail geantwortet. Ich mache das gleich noch einmal direkt auf eurer website. Es wäre schön, wenn du auf meine Frage auch antwortest und keine Ausweich-antwort mit der ich nichts anfangen kann. Sorry, wenn es sich jetzt etwas nervig anhört! Denn ich kann kein Update nach dem herunterladen machen - fehlermeldung!!!!!!

  • Lieber Christof, wie bereits schon mehrmals geschrieben - funktioniert es nach dem herunterladen NICHT. Ich habe beim Ticket direkt auf die Mail geantwortet. Ich mache das gleich noch einmal direkt auf eurer website. Es wäre schön, wenn du auf meine Frage auch antwortest und keine Ausweich-antwort mit der ich nichts anfangen kann. Sorry, wenn es sich jetzt etwas nervig anhört! Denn ich kann kein Update nach dem herunterladen machen - fehlermeldung!!!!!!

    Was für eine Ausweichantwort habe ich dir den gegeben? Soll ich hier im Forum öffentlich Fragen zu deiner Lizenz beantworten?

    Außerdem gibt's dazu ein Ticket welches beantwortet wurde und du antwortest hier in Threads die mit dem Thema deiner Lizenz selbst nichts zu tun haben.

    Sorry - doch nicht ganz genauso, denn der Unterschied bei dem Suchwort war jetzt: E-Lastenrad ... da schmiert mir Wordpress ab!

    Also wenn ich eine Liste mit Kategorie ALL und dem Suchwort "E-Lastenrad" erstelle, bekomme ich mit dem Keyword keinen Fehler mehr? Wie genau schmiert es ab?


    lg Christof