Posts by Amboss

    Hi,


    bei deinen beiden hat es bei mir auch nicht funktioniert. Sollte eigentlich in ungefähr so aussehen.

    [Blocked Image: https://www.bilder-upload.eu/bild-82755d-1546267776.jpg.html]


    Wobei ich auch noch Probleme mit der Darstellung habe. Ich suche noch eine Möglichkeit die Variationen nebeneinander und nicht übereinander anzuzeigen. Ausserdem wird das Font Awesome Icon von Amazon bei mir nicht angezeigt in der neuen Box.


    Grüsse


    Amboss

    Hast du die Produktseiten aktiviert ? AT-Einstellungen - dann der Reiter Produktseite - Häkchen bei aktivieren.

    Oder Woocommerce ? AT-Werkzeuge - dann den Reiter woocommerce und dort alle Einstellungen tätigen - hierfür am besten nochmal AT - Woocommerce lesen.

    Und dann hast du auch noch AT-Einstellungen - dann den Reiter Erweiterte Einstellungen - hier findest du den Standard-Importstatus, den du festlegen kannst.


    Grüsse

    Amboss

    Hallo,

    damit solltest du das bekommen:

    Code
    1. $formatter = new atkp_formatter(null, null);
    2. $myproduct = atkp_product::load($product_id);
    3. $minoffer = $formatter->get_minoffer($myproduct, true, null);
    4. $price = $formatter->get_offer_price($minoffer);


    lg Christof

    Das war wohl ein Anwender-Fehler vorher....

    Zurück zum minprice. Leider bekomme ich dort im product updated2 Hook eine 0 mit deinem Code zurück.


    p.S.: Kann es sein, dass beim Update minprice und maxprice vertauscht wurden ? Sieht bei mir in den Vorlagen jedenfalls so aus.


    Vielen Dank.

    Amboss

    Den regulären Preis. Die "weiteren Angebote" werden nicht in woo übertragen nur der Preis aus dem Original-Shop. Nichts wurde verändert ausser das Update auf 2.4.

    Sagen wir der Original shop aus dem das Produkt importiert wurde ist xxx. es gibt aber noch 2 weitere Angebote, diese werden auch in AT angezeigt. Beim speichern, wird aber nur der Preis von xxx an woo übertragen.

    Die Preise werden nicht mehr übertragen. Egal ob ich ein manuelles Update mache.


    Es ist alles in At vorhanden, aber es wird nicht übertragen.

    Schonmal Danke. Aber ich glaube es gibt erstmal ein Problem mit dem 2.4 Update. Leider werden jetzt gar keine Angebotspreise an woocommerce übermittelt.


    Bin gerade an den Comp gekommen und habe leider festgestellt, dass keins von den "weiteren Angeboten" an woocommerce übermittelt wurde.....hatte vorhin geupdated und war dann erstmal weg. Jetzt hat AT ein auto-update der Produkte gemacht und leider sind nur die Preise vom Shop, indem es importiert wurde, vorhanden. Argh...;(;)


    Grüsse

    Amboss

    Hallo,

    damit solltest du das bekommen:

    Code
    1. $formatter = new atkp_formatter(null, null);
    2. $myproduct = atkp_product::load($productid);
    3. $minoffer = $formatter->get_minoffer($myproduct, true, null);
    4. $price = $formatter->get_offer_price($minoffer);


    lg Christof

    Ich errechne damit den "Rabatt", gleichzeitig setze ich eine Metafeld, womit eine Sortierung im Shop möglich ist. Da fehlt mir dann leider der günstigste Preis bei manchen Produkten.

    Im Moment nutze ich product updated2 Hook.

    Danke und Grüße

    Amboss

    Minprice wird erst mit den Platzhaltern erzeugt. Den kannst du nicht abgreifen weil die Angebote erst nach dem Woo-Export geladen werden.
    Mit dem nächsten Update wird es aber eine Funktion geben mit der du zumindest den Stand zu diesem Zeitpunkt abrufen kannst.


    lg Christof

    Wo finde ich die Funktion im update ?


    Danke.

    Hi,


    gibt es irgendwie die Möglichkeit den %minprice% abzugreifen ? Beim Hook um das Produkt zu woocommerce zu übertragen, wird der minprice leider mit 0 übertragen. Andere Felder funktionieren wunderbar.


    Vielen Dank.


    Amboss

    Hi,


    ich muss mich hier auch nochmal einklinken. Mich ärgert dasselbe Problem.

    Super danke schön Christof.

    Habe die Sachen jetzt einmal manuell korrigiert. Hoffe, dass der Cronjob das dann nicht wieder zertört. Aber Du hast ja gesagt, das kann nicht passieren ;-)

    Schönen Montag Abend noch.

    LG

    Gaby

    Hast du das Problem jetzt behoben bekommen ? Ich merke, dass es bei mir bei Artikeln passiert, die eine hohe Anzahl an Variationen haben.


    Danke.


    Amboss

    Hi,


    ich habe mal eine Frage bezüglich des von Amazon übermittelten Preises. Ich habe z. B. ein Produkt, dass nicht aktualisiert wird, obwohl bei AT alles richtig ausgeführt wird. Der Preis wird falsch angezeigt und es wird eine eine Zahl im Prozent gespart Fenster angezeigt, obwohl überhaupt kein niedrigerer Angebotspreis vorhanden ist. Ich habe jetzt alles ausprobiert, manuell updaten, manuell preis geändert und wieder geupdated, auf einer Staging Site habe ich das Produkt gelöscht und neu importiert. Selbes Ergebnis. Ist das ein Fehler in der Amazon Api und hat jemand ähnliches beobachtet ?


    Danke.


    Amboss