Probleme mit Performance, Ladezeiten

  • Hallo,


    gerade da Mobile wichtiger wird, ist AT mittlerweile mein Flaschenhals bei der Performance. Im Grunde brauche ich eine Frontend-Darstellung, die die Ladezeit im Blick hat.


    Seit kurzem funktioniert die JS-Deaktivierung. Das ist schon mal gut.


    Wie kann ich denn so ziemlich alles andere von AT abschalten, dass es im Frontend wirklich nicht geladen wird?

    • Ich brauche nur ein oder zwei Vorlagen, die Bild, Preis, Shoplink und einige Standardfelder beinhalten.
    • Die Blade-Vorlagen ins Child-Theme packen? Ordnerstruktur nach Anleitung?
    • Das CSS dafür ebenso ins Child-Theme?
    • Was sonst noch?


    Mit den besten Grüßen

    Matt

  • Hallo,

    was genau macht bei dir den Flaschenhals bei AT? Die Scripte oder wie meinst du das?


    Das kannst du deaktivieren:


    Disable internal JavaScript library

    "select2"-Felder deaktivieren (nur bei Javascript-Fehlern aktvieren)

    "select2"-Felder im Frontend deaktivieren (nur bei Javascript-Fehlern aktvieren)

    Lightslider deaktivieren

    Chart.js deaktivieren


    Zusätzlich das:

    Alle Styles vom Plugin deaktivieren


    Dann wird nix mehr zusätzlich geladen. CSS musst du dann halt selber einfügen über dein Theme. Blade Vorlagen kannst du auch in der DB lassen, das wird über das Filesystem sicher keinen unterschied machen.


    Nur Interessehalber: Welche Plugins und welches Theme nutzt du den aktuell auf deiner Seite?


    LG Christof

  • Hallo Christof,


    ich habe alle Skripte deaktiviert. Das hat der Seitenperformance schon mal sehr gut getan. Mit einigen weiteren Verbesserungen bin ich jetzt bei 98 Mobil und 100 Desktop bei Pagespeed Insights.


    Ein Problem hatte ich durch die Abschaltung: viele Klicks verloren. Ich habe das erst nach einigen Tagen herausgefunden, warum die Buttons im Frontend nicht mehr funktionieren. Die Checkbox "Affiliate-Links mit JavaScript öffnen" war aktiviert. Hier wäre eine interne Prüfung, die einen Warnhinweis ausgibt, ganz gut. Sozusagen ein Verbesserungswunsch! :-)


    Mit welchem Skript wird diese Funktion generiert? Das Linkziel zu verstecken finde ich nämlich ganz gut. Ist es möglich, dass Du diese Funktion ressourcenschonend separat als Skript bereitstellst - evtl. mit Vanilla Script?


    Eigenes CSS wird dann als nächstes angepackt. Ich nutze Astra Pro auf meiner Live-Seite. Im Staging habe ich aber viel ausprobiert, um die Flaschenhälse zu finden. Hier nutze ich auch das "nackte" Generate Press.


    Viele Grüße

    Matt

  • Hallo Matt,

    ist halt immer so eine Sache.. bei 98 und 100 - man kann es bei der Optimierung auch ein wenig übertreiben :-)


    Eigentlich müsste folgendes JS reichen:



    Danach sollten die LInks wieder funktionieren, wenn du das wieder aktivierst.


    LG Christof