Ist AT PHP8-kompatibel?

  • ich würde gerne demnächst auf PHP8 umstellen. Ist AT PHP 8-kompatibel?

    Ich würde darauf noch ein wenig warten. Es ist leider aktuell noch nicht kompatibel.


    LG Christof

  • PHP 8 wäre auch für mich wichtig, da Affiliate-Toolkit aktuell das einzige Plugin meiner Seite ist (neben ca. 25 weiteren Plugins), das nicht PHP8 kompatibel ist.


    Fehlermeldung sieht so aus:


    2021/04/28 07:27:16 [error] 52705#52705: *1623 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Exception: list not found: in /www/mySecretSite/public/wp-content/plugins/affiliate-toolkit/includes/atkp_list.php:88

    Stack trace:

    #0 /www/mySecretSite/public/wp-content/plugins/affiliate-toolkit/includes/helper/atkp_template_parameters.php(27): atkp_list::load('')

    #1 /www/mySecretSite/public/wp-content/plugins/affiliate-toolkit/includes/helper/atkp_template_helper.php(138): atkp_template_parameters->__construct(false, '', '', 'notset', false, '', '', '', '', '')

    #2 /www/mySecretSite/public/wp-content/plugins/affiliate-toolkit/includes/helper/atkp_template_helper.php(497): atkp_template_helper->createPlaceholderArray(Object(atkp_product), 1, '', '', false)

    #3 /www/mySecretSite/public/wp-content/plugins/affiliate-toolkit/includes/atkp_shortcode_generator2.php(1051): atkp_template_helper->getPlaceholders()

    #4 /www/mySecretSite/public/wp-content/plugins/affiliate-toolkit/includes/atkp_shortcode_generator2.php(96): atkp_shortcode_generator2->templat" while reading upstream, client: 2001:9e8:2052:c900:a197:b23f:e7fc:56ec, server: staging-mySecretSite.kinsta.cloud, request: "GET /wp-admin/admin.php?page=link_whisper HTTP/1.0", upstream: "fastcgi://unix:/var/run/php8.0-fpm-mySecretSite.sock:", host: "staging-mySecretSite.kinsta.cloud", referrer: "https://staging-mySecretSite.kinsta.cloud/wp-admin/index.php"

    Gibt es einen Zeithorizont, wann damit zu rechnen ist?

  • PHP 8 wäre auch für mich wichtig, da Affiliate-Toolkit aktuell das einzige Plugin meiner Seite ist (neben ca. 25 weiteren Plugins), das nicht PHP8 kompatibel ist.

    Leider sind wir da auch von anderen Sdks abhängig. WIe z.b. Amazon oder eBay. Es wird daher noch ein wenig dauern bis wir auf PHP 8 umstellen können. Leider haben wir dazu auch keinen Zeithorizont aktuell.


    LG Christof

  • Mein Hoster hat mich informiert, dass ich nur noch einen Versionssprung von PHP 8 entfernt bin. Aktuell läuft noch 7.x als Standard und 8.0 ist bereits als Alternative wählbar. Eine ältere 7.X-Version wurde jetzt abekündigt. Die Zeit für PHP 7.x läuft also ab.


    Bis wann denkst du, habt ihr AT PHP-8-kompatibel? :)

  • Bis wann denkst du, habt ihr AT PHP-8-kompatibel?

    Das wird noch ein wenig dauern. Das liegt auch an den genutzen API-Sdks die das noch nicht können. Kann da nichts konkretes dazu sagen.


    LG Christof