Ebay Liste auf Basis eines Suchbegriffs erstellen funktioniert nicht

  • Hallo Leute,


    Ebay habe ich via API erfolgreich eingebunden. Ich kann auch ohne Probleme einzelne Produkte anlegen bzw. ausgeben. Nur eine Sache funktioniert nicht: Anlegen einer Liste auf Basis eines Schlüsselbegriffs. Folgende Fehlermeldung erhalte ich: "Request Exception: Invalid property type provided for entriesPerPage. Expected integer but got string"

    Diese Listenfunktion ist mir hier wichtig, da ich gerne auch Produkte von privat einbinden möchte und diese verschwinden ja schnell wieder.


    Der Fehlermeldung nach erwartet die Api einen Eintrag "Einträge pro Seite". Hat dies etwas mit der Option "Limit" bei der Konfiguration der Liste zu tun? Ich bin leider ratlos.

    Bei der Auswahl der Ebay-Kategorie bekomme ich übrigens auch nur die englischen Kategorien angezeigt. Aber dies ist normal, oder?


    Wer weiß Rat? Würde dies jemand vielleicht einmal bei sich ausprobieren und schreiben, ob es geht? Also z. B. "altes Buch" als Schlüsselbegriff wählen.

    Ziel ist es bei mir, dass mir dann einige Angebote zu alten Büchern ausgegeben werden und dass diese nach dem nächsten Cron aktualisiert werden.


    Gruß


    Thomas

  • Hallo Thomas,

    das ist leider ein Bug der mit der aktuellen Version kam. Mit dem nächsten Update ist der Bug gefixt.


    lg Christof

  • Hallo Christof, das neue Update kam aber schnell. Jetzt geht es. Wunderbar! Jetzt kann ich für meine Blog-Artikel (die sich um alte Dinge drehen, die man heute neu nicht mehr kaufen kann) private Ebay-Produkte genau so wie neue Amazon-Produkte bewerben und zwar auf Basis eines Keywords / einer Liste, die sich (hoffentlich) selbst aktualisiert. So hatte ich mir das vorgestellt und das Plugin erfüllt seinen Zweck. Eine sehr gute Arbeit von Dir. Jetzt hoffe ich nur, dass die Ebay-Api sich nicht ständig ändert bzw. dass du selbst genügend weitere Kunden haben wirst, um am Ball zu bleiben.


    PS: Parallel zur Plugin-Aktualisierung hatte ich die PHP-Version meines Hosters auf eine aktuellere umgestellt. Es könnte also auch sein, dass das Problem daran lag. Ich bin wegen dem Widget darauf gekommen, was auf PHP 5.6 nicht geht. Wie auch immer: Jetzt geht alles und ich freue mich.

  • Hallo Thomas,


    einer Liste, die sich (hoffentlich) selbst aktualisiert

    Ja, das tut sie ;-)


    PS: Parallel zur Plugin-Aktualisierung hatte ich die PHP-Version meines Hosters auf eine aktuellere umgestellt. Es könnte also auch sein, dass das Problem daran lag. Ich bin wegen dem Widget darauf gekommen, was auf PHP 5.6 nicht geht. Wie auch immer: Jetzt geht alles und ich freue mich.

    Nein, das lag schon an dem Bug. Version ab PHP 5.6 wird unterstützt. :-)


    lg Christof