Preisvergleich

  • Hallo Toni,

    bitte überprüfe die folgenden Punkte (sind die Klassiker):

    1. Im Shop ist “Weitere Angebote automatisch laden” angehakt.
      Wenn es untergeordnete Shops sind, dann natürlich im übergeordneten Shop (z.b. Affilinet) anhaken.
    2. Im Produkt ist eine EAN vorhanden
      Nur mittels EAN/UPC wird ein Preisvergleich ermöglicht.
    3. Im Produkt unter weitere Angebote sind Zeilen vorhanden
      Sind hier keine vorhanden: Checkbox für “vormerken” anhaken und auf aktualisieren klicken. Danach sollten hier Zeilen stehen mit Status “vorgemerkt”.
    4. Ggf. abwarten bis der Cronjob die Angebote nachgeladen hat (die werden nicht automatisch beim Produktimport geladen).
  • Moinsen,

    ich muss das Thema leider wieder aufgreifen. Zuerst: Beim affiliate-toolkit handelt es sich um das erste kostenpflichtige Plugin, welches ich bis jetzt für WordPress gekauft habe. Ich bin auch eigentlich ganz angetan von den vielen Funktionen, aber eine Sache möchte leider - wie so oft - nicht klappen: Der Preisvergleich.


    Ich verwende einmal AWIN mit mehreren Feeds (alle natürlich als einzelne Shops eingetragen) und einmal das Amazon Partnernet. Ich habe alle Punkte von dir schon beachtet und selbst nach längerer Wartezeit tut sich nichts. Das Problem: Die (automatischen und manuellen) weiteren Angebote bleiben stets bei "Für Preisupdate markiert" als Status. Auch das Erzwingen mit dem nächsten Speichern nützt nichts.


    Ich bedanke mich im Voraus für deine Hilfe und muss trotzdem nochmals ein großes Lob für dieses Plugin aussprechen!

  • Hallo

    bleiben stets bei "Für Preisupdate markiert" als Status

    Da läuft dann wohl nicht der Cron richtig. Nutzt du den WP-Cron oder den AT-Cron? Wenn du hier noch nichts Serverseitiges konfiguriert hast, ist das von deinem Traffic abhängig. Ich empfehle dir, das du das mal überprüfst und ggf. einrichtest: https://docs.affiliate-toolkit…liate-toolkit-einrichten/


    lg Christof

  • Guten Morgen,


    erstmal danke für eine so schnelle Antwort zu einer nicht gewöhnlichen Zeit. Ich hatte bis gerade noch den WP-Cron am laufen, habe jetzt allerdings umgeschaltet! Es funktioniert nun tadellos.


    Danke für deine Hilfe und das tolle Plugin!

  • Hallo,


    ich schließe mich mal dem Problem an.
    habe jetzt alles mögliche probiert. Es will aber nicht.

    AT Cronjob benutzt, kein Ergebnis.
    Plugin WP-Cron installiert und entsprechend alles umgestellt. Kein Ergebnis.
    Auf meinem Hoster einen Cron Job angelegt und alles eingestellt, kein Ergebnis.



    Habe mich an diese Anleitung gehalten https://docs.affiliate-toolkit…liate-toolkit-einrichten/

  • Hallo,

    was bedeutet der Screenshot? Beispiel das es keine Angebote gibt? :-)


    1) Wie ist der Cronjob eingerichtet und auf welche URL zeigt der externe Cron?

    2) Bei den Shops ist die automatische Suche aktiviert?

    3) Das Produkt hat im Feld EAN eine Nummer stehen?


    lg Christof

  • Der Screen sollte zeigen das keine Angebote angezeigt werden. Im Nachhinein tatsächlich eine unnötige Aktion meinerseits :D

    Zu deinen Fragen:


    Produkt hat eine EAN (habe für den Test eine DVD genommen)
    Laut Einstellungen werden unter weitere Angebote 7 weitere Shops gefunden, alle stehen auf "Für Preisupdate markiert"
    Die Shops haben Angebote automatisch laden aktiviert. In meinem Fall affili.net. Die Sub.Shops haben die Funktion bzw. Option ja nicht. nehme an sie übernehmen es von der Mutti.

    Cronjob verweist auf die URL: URL/wp-content/plugins/affiliate-toolkit/affiliate-toolkit-cron.php

    Wie gesagt, habe das Testprodukt gestern angelegt, hatte heute den ganzen Tag den Cronjob auf "Wordpress-Cronjob"
    Und mit dem plugin habe ich es auch versucht, hat ebenfalls nicht geklappt.

    AT ist derzeit auf eine Sub-Domain installiert, solange ich noch "rumspiele". Falls das evtl. einen Unterschied macht.

  • Hallo,

    alle stehen auf "Für Preisupdate markiert"

    Das ist schon mal gut. Dann liegts nur mehr am Cronjob.


    Cronjob verweist auf die URL: URL/wp-content/plugins/affiliate-toolkit/affiliate-toolkit-cron.php

    Wenn du die AT-Datei zur Aktualisierung verwendest, dann musst du auch den externen Cronjob verwenden und nicht den Wp-Cronjob.

    Du kannst die Datei auch mal direkt im Browser aufmachen wenn du in den Einstellungen "mit Ausgabe" auswählst. Dann siehst du was gerade passiert, das script wird auch ewig zum laden brauchen.

    ganzen Tag den Cronjob auf "Wordpress-Cronjob"

    Ja, wenn keine Besucher auf der Seite sind, kann schon sein das dann nichts läuft.


    lg Christof

  • Die Logos der einzelnen Händler muss ich selber einpflegen? Die werden nicht von der API gezogen nehme ich an?

    Doch schon, aber nur die großen. Geh mal auf einen deiner Partnershops und ersetze die Url des kleinen Logos, mit der des grossen. Bin mir aber nicht mehr hundertprozent sicher ob das so bei mir geklappt hat. Aber erinnere mich dunkel....:rolleyes:

  • Doch schon, aber nur die großen. Geh mal auf einen deiner Partnershops und ersetze die Url des kleinen Logos, mit der des grossen. Bin mir aber nicht mehr hundertprozent sicher ob das so bei mir geklappt hat. Aber erinnere mich dunkel....:rolleyes:


    Bei mir sind alle leer. Habe jetzt MediaMarkt, Saturn, buecher de und Otto geprüft.
    Habe bei allen weder ein kleines, noch ein großes Logo.
    "Shop-Logo anzeigen" ist bei Affili net angehakt.


  • Bei mir sind alle leer. Habe jetzt MediaMarkt, Saturn, buecher de und Otto geprüft.
    Habe bei allen weder ein kleines, noch ein großes Logo.
    "Shop-Logo anzeigen" ist bei Affili net angehakt.

    Habe es gerade mal durchgetestet, scheint ein Bug in AT zu sein. Du siehst ja ein Logo in der Liste deiner Shops, das heißt, es wird eins gespeichert. Das ist das große Shoplogo. Im Moment musst du wohl als Workaround das Logo in der Shop-Liste mit rechts anklicken und "Bild in neuem Tab öffnen" auswählen. Dann die URL kopieren und als Small-Shop Logo Url im Shop speichern.


    Alternativ kannst du auch Post Meta Inspector installieren, da wird die Url auch angezeigt.



    Grüsse und einen schönen Sonntag


    Amboss

  • Nur so als Anmerkung: Das ist nicht wirklich ein "Bug" im Plugin. das Affiliate-Netzwerk liefert hier leider dann nur einen Platzhalter zurück (den ihr hier seht).

    Ich kann es natürlich ändern, das hier default das größere Logo verwendet wird. Hat jetzt aber nicht die höchste Prio weil die Api eh bald eingestampft wird....


    lg Christof